Rotel amplifier problem - please help!!!

groovemachine

New member
Oct 24, 2011
11
0
0
Hi all,

I recently purchased a Rotel RA-06SE Amplifier on ebay.

It's been working fine for the few months i've had. Today the amplifier keeps jumping onto standby on it's own and making a clicking sound.

I was wondering if anyone else has had this problem and how to fix it.
 

John Duncan

Well-known member
Jan 8, 2008
2,029
15
19,695
First thing to do is make sure tout spraker wires aren't shorting out anywhere: disconnect them all an reconnect them, makin sure there are no stray wires escaping and touching.

If that doesn't fix it, sounds like a job for a repair shop...
 

Mooly

New member
Jun 10, 2011
1
0
0
Depends on your technical abilities as to how far you want to take it.

I'm not familiar with the Rotel as such but if the relay clicking out is the speaker relay (which gives a switch on delay and something called "DC offset protection") then probably the best you could hope for is that it is a dry joint (poorly soldered connection) on a compionent somewhere. Parts that run hot are the usual suspects. It's worth having a look. Beyond that and you are possibly looking at an intermitent fault such as a transistor that is thermally intermitent etc.

Do you get any loud noises from the speakers when this problem happens. If so that's a warning that the problem is generating a DC voltage across the speakers and you need to be very very careful as it's easy to burn out a speaker under such fault conditions.
 

groovemachine

New member
Oct 24, 2011
11
0
0
Hi Mooly,

Just a quick message to say thanks for the advice. I've got a couple of things I can try now without hopefully taking it in for repairs.

Cheers and Merry Christmas,

Andrew
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts