• If you ever spot Spam (either in the forums, or received via forum direct message) please use the Report button at the bottom of each post to make sure a Moderator can handle it quickly. Thanks for your help in keeping things running smoothly!

Rotel RA-10 Input Interference?

Nov 22, 2016
1
0
0
Hi guys. I just got Rotel RA-10. It's good and cheap amplifier so I though it would be a great way to start with hi-fi. However I've noticed interference when I switch to inputs which are not active (nothing plays trough them). When I increase the volume it picks up some music playing from the other input. Is that 'normal', should I worry? Should I ask for replacement? Here's the video. https://www.youtube.com/watch?v=GqLY_PcN4rg
 

Gray

Well-known member
Nov 27, 2015
996
618
5,770
Are the inputs completely open? (with no source connected to them) Looks like they are.

If so, you can short-circuit some RCA plugs and stick them in the unused input(s). That will quieten things down. (Short centre pin to ground in each plug)

Do that to the left and right (white and red) of each unused input. MAKE SURE THAT YOU DO NOT DO IT TO ANYTHING MARKED AS AN 'OUTPUT'.

To avoid the need for any soldering get a cheap, dual plug to plug interconnection lead. Cut in it half, bare back signal and screen wires and twist all them together. One dual lead will do two inputs.

Sounds OK by the way (even with your choice of music!) A good buy, no need to take it back for replacement.
 

Gray

Well-known member
Nov 27, 2015
996
618
5,770
The red wires in your picture are going into the centre (signal) hole of each socket.

What's needed is to connect the centre to the metal part of the socket that surrounds that hole. (Connect centre to outer of the SAME socket)

You need to do that on each of the two sockets on each unused input.

This is most easily done by connecting centre to outer together on each plug (either inside a plug or by twisting together all bare ends of the cut lead)

Try this just to prove to yourself that it works:

FIRST SET VOLUME CONTROL TO MINIMUM AND TURN OFF THE AMP.*

Now take two long pieces of your wire with bared ends. Push one bare end of each wire into the centres of each of the CD sockets. Undo that ground terminal (marked GND on the far left) and put the bared ends of each wire under it and screw it tight.

Now select the CD input, turn on and increase the volume. With music going into another input, there should be silence from that CD input - because you've shorted the input to ground, preventing any stray noise pickup.

Shorting at the plugs (or twisting signal and screen wires together) will be effectively doing the same thing.

*NEVER MAKE CONNECTIONS WITH THE VOLUME TURNED UP to avoid risk of speaker damage.
 

davedotco

New member
Apr 24, 2013
20
0
0
A lot of amps are like this, it is normal.

Just don't select an unused input and wind the volume up, why would you want to do that anyway.
 

Gray

Well-known member
Nov 27, 2015
996
618
5,770
davedotco said:
A lot of amps are like this, it is normal.

Just don't select an unused input and wind the volume up, why would you want to do that anyway.
No need to worry. But if he wants to do it and get silence.....

Speaking for myself, all my inputs are currently used but I've always physically covered any unused inputs to prevent contamination - so electrically shorted each at the same time. (But not because I like to listen to unused inputs at full volume!)
 
Nov 22, 2016
1
0
0
Oh I get it now. I've just tried with a spare cheap rca cable connecting red and white to ground (just touching it with the plugs) and it makes the music go away but I get humming sound even slightly louder than the music was. I guess I'll have to do better wiring with proper wires.

The reason why I ask is because I didn't know if the amp was defect.

Thank you for your help
. I'm glad I don't have to send the amp back to the store.
 

ASK THE COMMUNITY

TRENDING THREADS