• If you ever spot Spam (either in the forums, or received via forum direct message) please use the Report button at the bottom of each post to make sure a Moderator can handle it quickly. Thanks for your help in keeping things running smoothly!

Marantz M-CR603 firmware update today.

chebby

Well-known member
Jun 2, 2008
1,232
4
19,195
This time all my internet radio 'favourites' were preserved :)

Don't know what the update is for or what it changes. (Marantz UK site has no info.)

Has WHF recieved any info?
 

chebby

Well-known member
Jun 2, 2008
1,232
4
19,195
Update on the update...

...ironically enough, the detail of the latest firmware update is that... firmware updates no longer delete your internet radio 'favourites' list :)

(I phoned D&M in Ireland for details of the change.)
 

DIB

Well-known member
May 21, 2009
133
6
18,595
Good news. I'm currently running my update, hopefully I wont lose my stored stations either (fingers crossed).

.
 
A

Anonymous

Guest
I just ordered mine today (after 6 onths of dithering) along with MA BX2

Tell me I have done the right thing. DOes it all work or are people still ahving software problems??

Max
 

chebby

Well-known member
Jun 2, 2008
1,232
4
19,195
xeno said:
I just ordered mine today (after 6 onths of dithering) along with MA BX2

Tell me I have done the right thing. DOes it all work or are people still ahving software problems??
The only glitch I know of was fixed with this last update (as described above in my second post.)

When you get the unit, plug in speakers, plug in ethernet cable (connected to a spare socket on your internet modem/router) and only plug it into the mains and power on after the ethernet is connected.

The very first thing it will do then is download all the latest firmware (could take a while depending on your line speed).

You should be good-to-go after that.
 

DIB

Well-known member
May 21, 2009
133
6
18,595
Oops!

I've had mine for about 4 or 5 months now and I've done at least 3 firmware updates which have all gone fine (except for the aforementioned loss of stored stations), but this latest one is not going according to plan. Tried at lunchtime, and again just now and its stuck on "Authenticating". Nothing appears to be happening and it is not responding to my remote control or the buttons on the unit. As at lunchtime, the only way to clear it would be to unplug the unit and try and start again.

Any ideas?
 

DIB

Well-known member
May 21, 2009
133
6
18,595
Yep. Its been connected via Ethernet Cable from day one,

It's very strange as its always worked out well before with no hitch, taking about 20/25 mins to run the full update.

Might need to give the service centre a call.

.
 

DIB

Well-known member
May 21, 2009
133
6
18,595
Cheers. I'll give him a call on Monday.

Once I turn it off and on again it works fine as before, its just the update thats not behaving itself.

.
 

chebby

Well-known member
Jun 2, 2008
1,232
4
19,195
The instructions say to do the updates after at least two minutes have elapsed since you powered it on.

Is it possible you were a bit too quick off the mark when you tried it at lunchtime?
 

chebby

Well-known member
Jun 2, 2008
1,232
4
19,195
Retry instructions...

"If the update fails, remove and re-insert the power cord. “Update
retry” appears on the display and update restarts from the point at
which update failed. If the error continues despite this, check the
network environment."
 

DIB

Well-known member
May 21, 2009
133
6
18,595
chebby said:
The instructions say to do the updates after at least two minutes have elapsed since you powered it on.

Is it possible you were a bit too quick off the mark when you tried it at lunchtime?
I think that was the problem. I waited a good 15 mins this time and the update has gone through, and a quick doublecheck and its reading Latest Firmware, so problem sorted.

Cheers Chebby.

.
 

DIB

Well-known member
May 21, 2009
133
6
18,595
I go on Call Favourites as normal , the list of all the individual stations (all internet by the way) is still showing, but click on any of them and it comes up List Empty. I'll have to put them in again.

.
 
A

Anonymous

Guest
I am having similar troubles to upgrade.

Connects okay, and acknowledges have registered for Airplay upgrade.

Unit just gets stuck at Authentication ... stays in that state for hours. Have tried multiple times.

Any suggestions greatfully received.
 

chebby

Well-known member
Jun 2, 2008
1,232
4
19,195
athacker said:
Connects okay, and acknowledges have registered for Airplay upgrade.

Unit just gets stuck at Authentication ... stays in that state for hours. Have tried multiple times.

Any suggestions greatfully received.
Power off (standby then power off at mains then remove power cable). Replug power cable and power it all back on with ethernet cable connected directly to your internet router.

Don't do anything for at least a few minutes. Ignore/refuse any prompts to upgrade.

Then start the upgrade again.

Note: if - when you power it on - you get "M-CR603 Upgrade" displayed briefly (after the "Hello" display) then the upgrade is already complete.

If all fails, then call Marantz (D&M) support on Monday morning...

02890 279835
 
A

Anonymous

Guest
Thanks ... have progressed a little ... but getting stuck at the Updating screen.

Initially message says ...

Updating

13 mins

then ...

Downloading ....

12 mins

then

Updating

14 mins ***

then

Updating 13 mins ****

then

Updating 13 mins

then

Updating

12 mins

then

Downloading .....

12 mins

then

Updating

14 mins ***

then

Updating 13 mins ***

then

Updating 12 mins ****

then

screen goes blank, and we eventually start at the following again ...

Updating

13 mins

eventually it gives up and has error message

Download failed:AE (or come other code)
 
A

Anonymous

Guest
Picked up the Marantz MCR603 last week, all hooked up to the router and assured by the unit that my firmware was up to date, have successfuly upgraded/activated the airplay, and now the unit has signalled firmware update is available.

So, running through the usual process I seem to be stuck in the infinite loop, as 'athacker' above. Culminating in the downloading/updating 13/14/13/14mins then 'Connection Failed:A4' (or perhaps AE).

Oddly enough, I am seeing the "M-CR603 Upgrade" displayed briefly (after the "Hello" display) as chebby points out. But after a good power down/up airplay is still not working (although listed as active and upgraded in the 603 settings) and the firmware is still supposedly out of date.

I can live without the airplay for now, as seeing as the unit says that's all okay, I can only assume its a networking issue at my place, although IP's are all assigned correctly etc. So I'll go back to checking the Mac running Lion.

The infuriating thing is the constant failed updates when the connection is demonstratably working (through internet radio at least).

The quest continues at the moment. Will be sure to update!
 
A

Anonymous

Guest
Hey Guys

Just wondering if there was a new firmware update yesterday? 22/02/2012.

I got a message while listening to it even though it was complelty updated (with airplay)

Since the update I have been unable to use airplay via itunes however it still works with my iphone

ideas?
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts