Need help getting MQA with iPhone and Dragonfly Cobalt

nhf202

Member
Dec 3, 2021
9
0
20
The quick summary is that I can't get MQA quality streaming Tidal (or other apps) from my iPhone to a Dragonfly Cobalt or Hip Dac 2. (Thank you to anyone who can help with this!)

My setup:
- Tidal Masters (I've had the same result with Qobuz)
- iPhone SE (I've had the same result with an iPhone 8)
- Apple certified lighting to USB3 connector
- Dragonfly Cobalt dac (I've had the same result with an iFi hip dac)

What happens:
- Playing Tidal Masters, the dragonfly turns light blue, which signifies 96kHz
- Playing Tidal HiFi, the dragonfly turns green, for 44.1kHz

I have tried the Dragonfly and Hip Dac attached to my Mac laptop streaming Tidal Masters, and they both work then (turn magenta and sound great!).

At this point, the iPhone appears to be the only thing that is consistently not working, but I have no idea why. I've seen this setup work online (in fact, it's the setup that iFi shows in their YouTube tutorial:
View: https://www.youtube.com/watch?v=STo0eqRKP6A
)

Any help would be greatly appreciated. I've been googling for days with no luck.

Thanks!
 

Tinman1952

Well-known member
May 19, 2021
1,252
702
1,570
Hi. I think the problem might be your lightning to USB3 adapter. You say 'Apple certified' but I assume it is not the Apple CCK adapter? That is what I think you need to get the digital output 'unaltered' from the iPhone. See if you can borrow one or buy from Amazon to try....can always return if it doesn't work...but I think it will 👍
 

nhf202

Member
Dec 3, 2021
9
0
20
Hi Tinman1952,
I think that's what I have. It's the camera one. Here's the link on Amazon. It's also the one (I believe) in the iFi video. Did you mean a different one? I'd definitely try a different cable since that is the only thing I haven't swapped out yet :)
Could you link to the one you're talking about if I'm wrong about it being the same as mine?

Thanks!
 

Attachments

Tinman1952

Well-known member
May 19, 2021
1,252
702
1,570
Hi Tinman1952,
I think that's what I have. It's the camera one. Here's the link on Amazon. It's also the one (I believe) in the iFi video. Did you mean a different one? I'd definitely try a different cable since that is the only thing I haven't swapped out yet :)
Could you link to the one you're talking about if I'm wrong about it being the same as mine?

Thanks!
Hi. The Amazon link is the right one.... it's the same as mine which works fine with an iPad. I can get the MQA signal through to my DAC. So it seems it must be your phone 😕 Sorry...
 

nhf202

Member
Dec 3, 2021
9
0
20
Yes, these are Master tracks (the gold MASTER is up in the right corner). It does seem like it's my phone (I even tried another apple camera adaptor at the Apple store yesterday), but the fact that it happens on two different iPhones makes me wonder if it's a setting or something that I have wrong.

I've got all of the Tidal settings set to Master.
 

Attachments

Tinman1952

Well-known member
May 19, 2021
1,252
702
1,570
Yes, these are Master tracks (the gold MASTER is up in the right corner). It does seem like it's my phone (I even tried another apple camera adaptor at the Apple store yesterday), but the fact that it happens on two different iPhones makes me wonder if it's a setting or something that I have wrong.

I've got all of the Tidal settings set to Master.
Well it seems your cable is ok and your settings are correct... and the fact you have tried with two different iPhones should eliminate any 'bug' in the app (hopefully). I am just wondering what is that gold bluetooth symbol next to the MASTER logo?
 

nhf202

Member
Dec 3, 2021
9
0
20
Ah, sorry. I took that picture while connected to another speaker. Here is the image when connected to the Dragonfly. It has an audio source icon next to the MASTER logo that allows me to airplay to Sonos or other speakers.
 

Attachments

Tinman1952

Well-known member
May 19, 2021
1,252
702
1,570
Ah, sorry. I took that picture while connected to another speaker. Here is the image when connected to the Dragonfly. It has an audio source icon next to the MASTER logo that allows me to airplay to Sonos or other speakers.
Ok I thought the app was confused and thinking it was using bluetooth. Airplay has a limit of 16/48 so you do not want the phone using that. Make sure it is playing only to the iPhone itself.
 
Last edited:

Wil

Well-known member
May 8, 2020
375
103
1,070
Neither AirPort Express nor Apple TV is necessarily AirPlay. Look them up.
It will play max 16/44.1 music files but the limit is actually 16/48 as Apple TV and Airport Express products resample everything to 48kHz. I don't have to Google it..I know from experience.
 

Tinman1952

Well-known member
May 19, 2021
1,252
702
1,570
You don’t understand AirPlay. I’ll leave it to someone else…
Really? I use it every day to send audio from my iPad AND from my Apple TV..... do you?
I am not wasting my time trying to convince you what I know to be true...
This is the second time you have been unnecessarily aggressive and condescending to me. Please cease...
 

Wil

Well-known member
May 8, 2020
375
103
1,070
@Al ears You're knowledgeable, AirPlay—what’s its limits?
Really? I use it every day to send audio from my iPad AND from my Apple TV..... do you?
I am not wasting my time trying to convince you what I know to be true...
This is the second time you have been unnecessarily aggressive and condescending to me. Please cease...
 

Wil

Well-known member
May 8, 2020
375
103
1,070
Okay.
I have no idea as I don't use anything Apple and streaming is not my forte, I prefer wired connections in any set-up I use.
Perhaps it's the MQA packaging that's confusing the DAC in what it is actually receiving. If it were a DSD stream it would not be so confused.
And I’ll keep this reply simple. 8 years ago, I had to look into AirPlay because I bought a MS7000 (note how the PH-22 I mentioned to have given away was still with me when photo was taken):
DSC04499.jpg

I’m interested if anyone can prove (official) AirPlay protocol has changed beyond the limit of 44.1 kHz/16bit.
 
Last edited:

nhf202

Member
Dec 3, 2021
9
0
20
Update: I used all of the same hardware with my girlfriend's iPhone (same model as mine) and Tidal, and it works! I get magenta MQA audio.

So the problem is either a setting on my iPhone or something else with the iPhone. So far I've tried:
- Updating the iOS.
- Turning it off and on.
- Logging into Tidal with her login.

I can't figure out what setting I could have that's affecting this.
 

Tinman1952

Well-known member
May 19, 2021
1,252
702
1,570
Update: I used all of the same hardware with my girlfriend's iPhone (same model as mine) and Tidal, and it works! I get magenta MQA audio.

So the problem is either a setting on my iPhone or something else with the iPhone. So far I've tried:
- Updating the iOS.
- Turning it off and on.
- Logging into Tidal with her login.

I can't figure out what setting I could have that's affecting this.
I suggest swapping phones with your girlfriend......l😂
 

nhf202

Member
Dec 3, 2021
9
0
20
Update: I talked to Apple support and we decided to reset all of my settings. That did it!

So, I have no idea which setting specifically was doing this, but I'm now getting MQA through this setup. Hope this helps someone else in the future. I'll try to remember to update this thread if I figure out which setting it is.

Thanks, all (especially Tinman1952).
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts