Pioneer SC-LX83 and iControlAV Problem


New member
Jul 31, 2010
Hi can anyone help?

I would like to control my Pioneer SC-LX83 Av with the Pioner iControlAV iphone, ipad/ ipod app. But no matter what I try i cannot get it to work.

The error I get most is B27102, does anyone know what this is? this is from whatever device I use.

However when I use a new version of icontrolavv2, the app see's the LX83 but gives the error NoN Controllable Device and gives a link to the original app.

I have tried re- booting several times in different orders but to no avail, my BT homehub can also see the LX83. I have also set the ip address manually to aviod that issue.

The reason i want to control it this way is so I can have music in my garden / decking as an extra zone or B speakers without the need to purchase another amp just for the garden. All of my music is on itunes/ipad/ipod/iphone/ATV and the wireless works fine in the garden for these devices to act as a remote.

michael hoy

Well-known member
Oct 6, 2008
Found this on amazon's web site;

Ok, I got it to work! I sent Pioneer support an email and this was their response which worked perfectly:

"Thank you for contacting Pioneer Electronics, Inc.

Recommended Solutions:
Turn on the Pioneer receiver. Make sure that there is an ethernet cable connected between the Wi-Fi router and the receiver. Make sure there is no firewall preventing access. Unplug power to the router, then turn power off to the receiver and lastly get out of the iControlAV application. Plug in power to the router and wait a minute, then turn on the receiver and wait 20 seconds and lastly run the iControlAV application. Make sure that the receiver can see the Wi-Fi router, to check network settings in the receiver go into the "Home Menu", "System Setup" then Network Setup."

Once I turned of my wifi firewall and rebooted everything, it worked perfectly.

Frank Harvey

Well-known member
Jun 27, 2008
Sorry Mike, been really busy recently so haven't had a chance to try it. I will do when I get some time! :) Although, I assume the OP is talking about the iControlAV app, not the iControlAV2 app - the AV2 app states on my iPad that the 83 can't be controlled via the app when I try to connect.


I contacted Pioneer support for this same fix. My icontrolav app had worked previously and stopped a few months ago. I did not change my firewall settings but completed the power cycle as described and now it works great. I figured because it had worked previously and I had not changed equipment it was not likely to be a firewall issue. Make sure you follow the steps as described.


Latest posts