• If you ever spot Spam (either in the forums, or received via forum direct message) please use the Report button at the bottom of each post to make sure a Moderator can handle it quickly. Thanks for your help in keeping things running smoothly!

Rega RP1 turntable + multimedia speakers

Nov 19, 2016
1
0
0
Hello,

I'm new to the forum.

Almost a year ago a bought a Rega RP1 turntable on Amazon and I was told I only needed a Phono Box preamp to connect it to my current speakers.

My current speakers are a Sony SRS0211 Active Speaker System and they are decent quality so I'll rather not have to buy a new set if possible.

First time I tried to connect the speakers I realized that the speakers only have one jack cable and the phono box output needs two (red and white). I was told that if I buy one of those autoleads that splits it in two it will resolve the problem. That didn't work either.

Unfortunatenly Rega don't have a customer services department and Amazon won't help. I'm desperate to get it working but I contacted various Hi-Fi specialist shops and they aren't very helpful or they say what I'm doing should work in theory. When I try to read about it online it's all a bit too technical for me to understand.

I wonder if you guys have any piece of advice for me.

Regards,

Augusto.
 

davedotco

New member
Apr 24, 2013
20
0
0
Augusto Vera said:
Hello,

I'm new to the forum.

Almost a year ago a bought a Rega RP1 turntable on Amazon and I was told I only needed a Phono Box preamp to connect it to my current speakers.

My current speakers are a Sony SRS0211 Active Speaker System and they are decent quality so I'll rather not have to buy a new set if possible.

First time I tried to connect the speakers I realized that the speakers only have one jack cable and the phono box output needs two (red and white). I was told that if I buy one of those autoleads that splits it in two it will resolve the problem. That didn't work either.

Unfortunatenly Rega don't have a customer services department and Amazon won't help. I'm desperate to get it working but I contacted various Hi-Fi specialist shops and they aren't very helpful or they say what I'm doing should work in theory. When I try to read about it online it's all a bit too technical for me to understand.

I wonder if you guys have any piece of advice for me.

Regards,

Augusto.
And welcome to the forum.

I am guessing that what you have is a SRSD211 system.

If this is the case then what you need is a 2 phono to 3.5mm mini jack lead, simple as that. You say that you have bought a lead but perhaps somehow it is not of the right type, the right lead should work, it is really pretty simple.

Whar you need is something like this...

https://www.amazon.co.uk/s/ref=nb_sb_noss?url=search-alias%3Daps&field-keywords=jack+to+two+phono+cable

Any of the first 4 or 5 (or more) items will work, just order the correct length.

However, it you already have a cable like this and it does not work then you need to do some basic faultfinding.
 

davedotco

New member
Apr 24, 2013
20
0
0
Augusto Vera said:
Thanks. I've oredered one, let's hope it works.
I am assuming whatever 'splitter' cable to tried before was different, fingers crossed.

Worth carrying aot a few checks though, does your speaker system work ok with another source, a phone for example? How about your Rega, properly set up etc?

Let us know how you get on.
 
Nov 19, 2016
1
0
0
No luck yet.

Shortly after I ordered this: https://www.amazon.co.uk/Aptii-3-5mm-Phono-Audio-Cable/dp/B005M1LR5O/ref=sr_1_8?ie=UTF8&qid=1480016323&sr=8-8&keywords=jack+to+two+phono+cable I realized it probably won't work because because the speaker system also has a jack, you can see it on this photo, on the right:



So it looks like what I need is a female to 2 phono autolead like this one:



which is the same as the one I already bought and it didn't work. Maybe I bought the wrong one but it looks just the same.

With the new lead I bought I tried to connect the jack to that green bit where it says "phones" in case it worked but it didn't.

The speaker system works fine with my mac and with the TV. It mustbe something else...
 

davedotco

New member
Apr 24, 2013
20
0
0
The twin rca phono plugs should connect to the output of your phono pre-amp, the single jack to one of the input sockets on the rear of the amp.

Select the input you have chosen and you should be good to go.
 
Nov 19, 2016
1
0
0
davedotco said:
The twin rca phono plugs should connect to the output of your phono pre-amp, the single jack to one of the input sockets on the rear of the amp.

Select the input you have chosen and you should be good to go.
Yep.... When I said I wasn't tech savy I really meant it. It works!! Thanks guys.
 

ASK THE COMMUNITY

TRENDING THREADS