Rega Queen edition TT/ Brio-R electrical noise/hum - SOS from China!

Page 2 - Seeking answers? Join the What HiFi community: the world's leading independent guide to buying and owning hi-fi and home entertainment products.

paul darwin

Well-known member
Feb 21, 2012
0
1
18,500
Superallan10,

I have forwarded all communications to our Export Co-ordinator who will take up the issue with our Chinese Distributor to ensure that there is a completely satisfactory conclusion for you.

Thanks you again for your patience and understanding.

Paul Darwin

Rega Research
 

superallan10

New member
Oct 19, 2016
1
0
0
paul darwin said:
Superallan10,

I have forwarded all communications to our Export Co-ordinator who will take up the issue with our Chinese Distributor to ensure that there is a completely satisfactory conclusion for you.

Thanks you again for your patience and understanding.

Paul Darwin

Rega Research

I understand. Rega sold thousands of units already and its very unlikely a design issue. I believe so , and thats why i spent almost two months to figure out which part went wrong, and finally got another rp1 & another brior to test (you cannot imagine how hard it is in china. Plus I paid 25usd for the freight of new brior and the return of the old one,) I cross checked those units but the noise never changed. I really dont know what to do right now. (The only remaining item in the system is the rega rs3 speaker, though i dont think it can be the reason). It would be great if you can ask the general distributor in China to contact me. My email is superallan10@sina.com
 

superallan10

New member
Oct 19, 2016
1
0
0
Btw, i will be happy to invite the people from rega to my home and have an audition.(actually i already invited a local distributer to my home and he said "the noise is horrible"- he sells rega turntables but not amps, so he couldnt help me a lot.)
 

superallan10

New member
Oct 19, 2016
1
0
0
paul darwin said:
Superallan10,

I have forwarded all communications to our Export Co-ordinator who will take up the issue with our Chinese Distributor to ensure that there is a completely satisfactory conclusion for you.

Thanks you again for your patience and understanding.

Paul Darwin

Rega Research

still waiting for a response . The seller would not give me full refund because “the package was damaged”- omg, the package was damaged as soon as i received it! However, that's fine. I dont really want to return it. I'm waiting for Rega to find a people here in China whos capable of getting rid of the noise for me. Again, my email: superallan10@sina.com. Please ask someone to contact me as soon as possible. I spent 50 days on this issue already. i also spent much more money than ppl in US or UK for the TT/amp/speakers, and its really ridiculous that nobody in the whole country is able to help me.
 

paul darwin

Well-known member
Feb 21, 2012
0
1
18,500
Superallan10,

I have passed all of your / our communications to our export team who have contacted our China distributor who has promised to contact you as soon as possible but apparently he is tied up at the moment with the Guanzhou HiFi Show and unable to give the issue his full attention.

Please understand we are doing all we can to resolve the matter for you as quickly and efficiently as possible.

Paul Darwin

Rega Research
 

thescarletpronster

New member
Nov 17, 2012
10
0
0
superallan10 said:
admitted its a common issue. seems when using the brio r, rp1 combo,if you are using a japanese cartrige(nagaoka, audio tec or the stock Carbon)

Just a thought: Nagaoka cartridges are deeper than Rega's own, so if you install a Nagaoka you will have to increase the height of the tone arm (by 2mm, I think) for best results. I think, although I can't remember for sure, that it's the same in the case of Audio Technica. I'd be surprised if not raising the arm created horrid noise - I assume the sound reproduction just wouldn't be quite as good - but it might be one possible answer, or at least point in the direction of a possible answer.

Hope you find a means of getting good audio reproduction at home!

ps: I can't remember whether this has already been asked, and I don't have time to go back through the whole thread, but is it possible that the cartridge, rather than the turntable or amp, is at fault?
 

superallan10

New member
Oct 19, 2016
1
0
0
thescarletpronster said:
superallan10 said:
admitted its a common issue. seems when using the brio r, rp1 combo,if you are using a japanese cartrige(nagaoka, audio tec or the stock Carbon)

Just a thought: Nagaoka cartridges are deeper than Rega's own, so if you install a Nagaoka you will have to increase the height of the tone arm (by 2mm, I think) for best results. I think, although I can't remember for sure, that it's the same in the case of Audio Technica. I'd be surprised if not raising the arm created horrid noise - I assume the sound reproduction just wouldn't be quite as good - but it might be one possible answer, or at least point in the direction of a possible answer.

Hope you find a means of getting good audio reproduction at home!

ps: I can't remember whether this has already been asked, and I don't have time to go back through the whole thread, but is it possible that the cartridge, rather than the turntable or amp, is at fault?

Hi, thanks for your reply.

Im sure its not an issue regarding to the height of tonearm, because the electrical noise occurs as soon as i connect the cartridges. I dont even have to play the music.

Btw, a local distributor told me that yesterday another RP1 customer in Shanghai found the same issue. His amp is a Denon, also with only 2pin on the plug (no earth pin). Now i am starting to believe that its probably an issue with rp1's earthing design (through RCA ).

Just a little curious, as you are using brio-r as well, you never encountered such issue right? Does your brio only have 2 pin plug as well? Is it possible that it is because your rb303 tone arm is superior than rb101?

Thank you very much.
 

superallan10

New member
Oct 19, 2016
1
0
0
paul darwin said:
Superallan10,

I have passed all of your / our communications to our export team who have contacted our China distributor who has promised to contact you as soon as possible but apparently he is tied up at the moment with the Guanzhou HiFi Show and unable to give the issue his full attention.

Please understand we are doing all we can to resolve the matter for you as quickly and efficiently as possible.

Paul Darwin

Rega Research

hey, just some more updates.

Another customer in Shanghai encountered the same issue, ( his equips are rp1 performance+ a denon amp)

Plus, my seller in Guangzhou tested the same combo as mine in his shop (queen edition+brio r) ,
Huge noise as well. I will be happy to provide his contact detail if you want.

Also, a local distributor in shanghai tested rp1+a very old amp with 3 pin plug, no noise.

As i said i am tired of being a QC tester. I hope rega can pay more attention on this issue. Please follow up.
 

stevebrock

New member
Nov 13, 2009
183
0
0
Bloody hell - poor chap

Hope Paul sorts this out for you - he has helped me many times in the past - however Ive moved away from Rega Electronics now
 

TRENDING THREADS