Question Quad Vena II Play - network connection not working


Jan 3, 2024
Visit site
I am having some issues connecting the device to the network, Bluetooth works fine. I tried connecting it with Standard mode:
After switching the Vena II Play on, press and hold the Wi-Fi SET-UP button on the rear panel for 8 seconds. For the first 4 seconds the Wi-Fi LED will double-flash and beep with a warning tone - keep holding the button down and after 8 seconds the Wi-Fi LED will flash quickly and also beep with a warning tone. The Standard connection mode is now active and the Wi-Fi hotspot will be found after 20 seconds. Then the Wi-Fi LED will flash-breathe with a slow fluctuation between off and on (reflected by the white LED on the front panel). You can now use your Android or IOS device to enter the Wi-Fi password using the Play-Fi APP
Nothing happens after 4 or 8 seconds, there is no sound and the LED is not flashing. LED is turned on and after few minutes it starts flashing. I tried to find wifi network and used Play-Fi app but I got nothing.

I tried connecting it with cable
After switching on the Vena II Play, the white NET LED on the front panel and red Wi-Fi LED on the rear panel will flash during the initialize phase of Wi-Fi mode. the white NETLED will slow-flash when the device goes into the wired network connection. If the connection is successful, the red Wi-Fi LED will go off, but the white NET LED stays lit.
In this case, LEDs keep flashing and never stop.

I tried to reset the device and it doesn't help. Does anyone know if I am doing anything wrong or is the device broken?


Latest posts