• If you ever spot Spam (either in the forums, or received via forum direct message) please use the Report button at the bottom of each post to make sure a Moderator can handle it quickly. Thanks for your help in keeping things running smoothly!

Musical Fidelity X-AS100 Power Amp

admin_exported

New member
Aug 10, 2019
2,556
2
0
Just got hold of Musical Fidelity X-AS100 Power amp

Hooked it up to M-Dac and linked through to B+W ASW608 Sub Woofer all works fine

Musical Fidelity say dont turn off amp leave on, but when I turn of M-Dac the amp starts buzzing ?

Should it do this ? if not where is the fault ?

PS all cables swapped and checked (all new today )
 

gregvet

New member
Dec 24, 2008
102
0
0
I don't know if it is normally or not I am afraid. Could it be picking up interference from the mdac power supply?

how does it sound when the mdac is turned on?
 

PEAYEL

New member
Dec 13, 2008
19
0
0
This could be an earth loop on the circuit/supply that you have.

A simple test will be to run a long extension cable from a socket upstairs (as these should be separate circuits) and plug in one of the items into the extension cable. There should be no humm then.

If so you will need to examine which item can do without the earth wire being connected. Probably none. If it persists you need to set up a simple central earth point for your gear or get an extension socket with an earth lift on it.

Obviously if your not sure then an elctrician can do this for you.

All the best.
 
A

Anonymous

Guest
It does sound like an earth loop problem just quickly put it all on desk in office whilst looking for best place to locate and off course it's all plugged in under desk along with pc router sub woofer phone lamp monitor printer etc etc. mains leads signal cables speaker cables Ethernet all interacting and crossing each other may be the issue !!

Will try relocating to its own circuit and move cables etc over weekend and see what happens
 
A

Anonymous

Guest
Ok lets try and figure this one out now ?

Powered Amp from downstairs ring and M-Dac from Upstairs amp on M-Dac off low volume buzzing. powered form same source still buzzing. Removed line out to sub still buzzes left only new Chord Cobra interconnect so swapped that out with old chord pair works fine no buzzing when M-Dac turned off ?

Is it that Chord Cobra cables are not earthed at both ends ?
 
A

Anonymous

Guest
Just spoke to Chord Company Cobra plus shields not connected...

Guess i need to find cables that have shields connected
 

SteveR750

Well-known member
Mar 11, 2005
511
16
18,895
I reviewed the M-DAC elsewhere, it was pretty poor on mains interference in my system, despite the claims (and size) of the psu, to the point USB connection from my laptop was pointless. The dacmagic+ has a mains hum issue too, but thats helped by a ground lift switch.

More expensive DACs don't seem to have the problem
 
A

Anonymous

Guest
So should I try and track down source of earth loop ?

earth all units to single point ?

play around with terminated screened cables ?
 

ASK THE COMMUNITY

TRENDING THREADS