Help with turntable -> Amplifier

dannywalkerrr

New member
Jul 1, 2016
1
0
0
Hi, I'm becoming frustrated over an issue i'm having with my new hi-fi setup,

I've just bought an Audio Technica LP120 turntable & a Cambridge Audo Topaz AM10 Amplifier. The issue is that the Turntable does not seem to be compatable with the Amp, because when using an alternative Turntable, the Amp works fine. Anyone got any ideas? The Speakers work fine, and the AT LP120 Turntable works fine seperately.

Any help would be great!

Dan
 
dannywalkerrr said:
Hi, I'm becoming frustrated over an issue i'm having with my new hi-fi setup,

I've just bought an Audio Technica LP120 turntable & a Cambridge Audo Topaz AM10 Amplifier. The issue is that the Turntable does not seem to be compatable with the Amp, because when using an alternative Turntable, the Amp works fine. Anyone got any ideas? The Speakers work fine, and the AT LP120 Turntable works fine seperately.

Any help would be great!

Dan
How do you mean the turntable works fine separately?

When you connect to the amp you must use the inputs specifically for a turntable on the back of the amp and switch off the turntables own phono preamp.

Did the alternative turntable have an inbuilt preamp? Can we take it you didn't buy them in the same place?

Why did you buy that turntable when your amp already has a phono preamp Sorry for all the questions, and welcome to the forum.
 

dannywalkerrr

New member
Jul 1, 2016
1
0
0
Hi Al Ears, the alternative Turntable is an Ion TTUSB05 which has a line output with intergrated preamp, the turntable i'm struggling to get to work has switchable phono pre-ampwith RCA outputs.

I've connected the turntable into the correct inputs on the amplifier & turned off the turntable's phono preamp but still no luck.

The turntable works fine on it's own putting it through a seperate speaker system, just not through this Amp!

Cheers, Dan
 
dannywalkerrr said:
Hi Al Ears, the alternative Turntable is an Ion TTUSB05 which has a line output with intergrated preamp, the turntable i'm struggling to get to work has switchable phono pre-ampwith RCA outputs.

I've connected the turntable into the correct inputs on the amplifier & turned off the turntable's phono preamp but still no luck.

The turntable works fine on it's own putting it through a seperate speaker system, just not through this Amp!

Cheers, Dan
How do you put it through a separate speaker system without going into an amplifier? Perhaps it has a fault somewhere. This is what happens if things are over complicated. If the only change is the phono leads instead of a line output then are you sure they are going to the correct inputs on the amp and the right source is selected on the amp? If you cannot get it to work take it back to the dealer.

If you have the turntable connected to the amplifiers phono inputs and it still doesn't work then perhaps the cables from the turntable are faulty.

Check the Phono / line switch is in the correct position on the turntable.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts