• If you ever spot Spam (either in the forums, or received via forum direct message) please use the Report button at the bottom of each post to make sure a Moderator can handle it quickly. Thanks for your help in keeping things running smoothly!

Broken receiver.

Zeeman92

Well-known member
Nov 9, 2014
11
2
10,525
Hello, I've been a registered member for a while, but I am new to posting on the forum, I hope someone can help me. My Pioneer receiver has had a dim display for a while, so I rather stupidly decided to dismantle and clean the connections with contact cleaner, I knew this probably wouldn't solve the issue but I didn't see the harm either. Upon reassembly the unit fails to fire up, just the initial audible click and then nothing happens.

Would any of you have any idea what this may be? Any help would be much appreciated, thank you. The unit is a SC-LX59
 
Last edited:

Gray

Well-known member
Nov 27, 2015
1,325
833
12,070
Best case, you've disturbed a connector that just needs reconnecting.
You've got 2 choices:
1) Do what Al said and get someone to look at it.
2) Carefully open it up and have a good look at all push-on connectors.
Look for obvious signs of trouble such as wires you may have trapped / damaged on reassembly.

Some would say you've got nothing to lose with option 2.
On the other hand you've probably heard the saying, "Out of the frying pan, into the fire"

Good luck with avoiding the fire.
 
  • Like
Reactions: Al ears

Zeeman92

Well-known member
Nov 9, 2014
11
2
10,525
Thanks everyone, I decided to have another look and as you can imagine, it's a bit of a maze inside and two unplugged wires blended in rather well with their surroundings. Other than the issue of the dim screen still persistent, the unit now works fine.
 
  • Like
Reactions: Gray

ASK THE COMMUNITY

TRENDING THREADS