Naim Uniti 2 - Issue Fault 28


New member
Aug 10, 2019
Dear Community,

I purchased a NAIM UNITI 2 (which is 3 days old) and I’m struggling with the following issue:

Fault 28
Bridgeco boot fail

The first time the issue occurred when I tried to play music from my connected USB-Stick. Today the issue appeard again when my machine was switched on for aprox. 4 hours and I tried to connect to my router.

The problem is that whenever this fault occurs my NAIM freezes. I have to shut it down and turn it on again but after that UPNP and USB doen’t work! The NAIM (with all it functions) only works again if you shut it down for a long period of time.

I guess there must be a software issue that produces this “Fault 28 Bridgeco boot fail”. It may has something to do with the WIFI and/or the USB!

HuwJ wrote: “Hi Kaver, I wish I could tell you that everything will be fine, but I can't. The card in your NDX has broken and will need to be replaced. I tried all sorts to re-boot then phoned Naim support - who told me to return it via my dealer. Mine was about a month old when it happened.

You hope that when you buy a £3k bit of kit that it will last a while. Having said that I had it back within 10 days.“

I don’t think that the card is broken because my NAIM worked fully after the waiting time!

Kaver wrote: “Very strange I would have thought its just a simple software problem, I can use the digitalt inputs if I when I turn it on quickly swith to another input than the upnp input. Anyway thanks a lot for your very quick response.”

I could do the same!

HuwJ responded: “I could do the same. I think it was the network card that was causing a problem but USB was not working either.”

Same for me!


The good thing is that the NAIM fully works again after a long waiting time but honestly it is a little bit disturbing to not being able to listen to your music when you want to.

So my questions are: Why does this FAULT 28 occur? Who has the same problem with his NAIM product? How did you produce the “Fault 28”?

It seems that I’m not the only one dealing with this issue:

Product specifactions:

Naim Uniti 2

Version 3.15

Boot 2.1.9

Andrew Everard

New member
May 30, 2007
I think it's a problem best sorted by taking the unit back to your retailer for replacement, rectification or refund. The code description suggests the firmware for the streaming board (the Bridgeco bit) isn't loading correctly – it should be rectified by a clean install of the firmware.

I'd usually suggest a call to Naim, but unfortunately the company is on its week-long summer shutdown, and normal service will be resumed next Monday.


Dear Mr. Everard:

Thank you for your fast reply & support!

I will return the NAIM UNITI 2 to my retailer.



Today I tried to start UPNP but I'm still getting the error. So the "waiting" didn't work anymore!