Getting Dolby Digital to work on Sky HD using an Onkyo 806

admin_exported

New member
Aug 10, 2019
2,556
2
0
I am using an Onkyo TX-SR 806/ Sky HD.

Ok I now know that Sky HD don’t send DD via the HDMI (god only knows why not thought) this is causing me a major problem as follows.

I set the Onkyo to accept CBL/SAT via HDMI from Sky, no problem there, the picture is great but the sound is only in stereo.

So I then connect the optical cable from sky into the Onkyo and then tell the Onkyo to accept Sky’s DD audio signal via Optical.Problem is that the amp seems to only want to process the crappy stereo audio signal that it’s receiving via the HDMI cable once it’s connected, and prioritises it over the DD optical signal and in effect just ignores it, hence I still just have stereo.

However the set up within the Onkyo set up menu appears to be correct. Any help would be greatly appreciated, I note that both Andrew Everard and Clare Newsome have both commented on similar problems and hope that they can help with this one, please????

NB: I know that the Onkyo is getting the audio signal via Sky, as if I plug the HDMI directly into my Plasma and the Optical into the Onkyo I get full DD from the amp, but as soon as I plug the HDMI back into the Onkyo the sound drops back to Stereo.
 

aliEnRIK

New member
Aug 27, 2008
92
0
0
Whats the point in plugging the HDMI into the amp at all?

Because of the way the boxes are made the best setting for SD signals is setting to 1080i. Which means you wouldnt benefit from any extra processing anyways
 
A

Anonymous

Guest
Hi thanks, keeping it simple the Onkyo has 5 HDMI inputs and 1 output, so it will do all of the switching inside the amp it has nothing to do with the picture quality. my sistem is all built in, with sockets on the wall and all the cables running inside the walls. if i have to plug Sky HD directly into my Plasma I would require a further 3 HDMI cables to run into the sockets and then inside the walls. but if i can't sort this out then i guess i'll be investing in some more HDMI cables.
 

Andrew Everard

New member
May 30, 2007
1,878
1
0
Not sure about the 806 right now, but I can tell you the HDMI and optical through thing works perfectly on the TX-SR875 I have here, which is basically the same unit in operational terms.

I have CBL/SAT set to OPT 1 in the Digital Input menu (1-4), and - umm, that's about it.

Oh and HDMI Audio Out set to Off in the Hardware Setup/HDMI menu (7-5).

Beyond that, I didn't have to change anything.
 

aliEnRIK

New member
Aug 27, 2008
92
0
0
Im sure ive heard of this before. Ive not got an Onkyo myself so unsure. But I believe theres a setting somewhere to change the 'priority' of which input to use (HDMI being the default priority)
 
A

Anonymous

Guest
I'm still struggling with this on my Onkyo 606. I've now added a digital optical cable and set the digital audio in to OPT1 and the Dolby out on the Sky HD box. However, when I scroll the display button on the Onkyo remote it is still saying the input is PCM 48 kHz when watching content that is advertised as being DD. I presume it should say Dolby Digital?

Any ideas?
 
A

Anonymous

Guest
I had the same problem on my 606. You have to press the Digital Input button (assuming you have one) on the front of the amp. So first select CBL/SAT then hit the button until the correct Optical is shown. I found this under the first time setup in the manual. When playing DD, the amp does show Dolby D.

Hope this helps.
 
A

Anonymous

Guest
Can't remember exactly where it is as I am at work. But you need to go in to the menu's and there is a list of all the HDMI's.

for each you can set the signal output. ie. HDMI or Opt 1 /Opt 2.

Set the HDMI out to which ever optical you have connected to sky and it will send it via that instead of the HDMI in stereo.
 
A

Anonymous

Guest
Right problem solved hopefully this will help other Onkyo 806 owners. Follow this and you will have glorious DD.

Press set up on the Onkyo remote

Go to 1. Input assign and press select

Go to 1. HDMI input and press select

Set the CBL/SAT to the corresponding input on the amp, which you have plugged into. In this case your SKY HDMI input goes into HDMI 3 on the amp.

Press return on the remote to go back a stage and return to the input assign screen.

Go to 3. Digital Audio Input and set the CBL/SAT option to OPT1 and press return to exit the menu; you should now have the SKY channel on your TV, with no Onkyo menus showing.

Put the remote down and look for the "DIGITAL INPUT" button on the amp (it's under the front flap)

Press the Digital Input button repeatedly until the display on the amps screen reads OPT1 AUTO.

You will now see that the amp is giving you Dolby Digital and is now processing the DD signal it's receiving via the Optical lead and ignoring the stereo signal it's getting from the SKY HDMI. The Onkyo is now only using the HDMI to send the picture signal.

I hope that this helps other people with the same problem; it should be the same for all Onkyo's not just the 806.
 
A

Anonymous

Guest
clarkernucci...........

......you are my new best mate!!!

I never knew I had a digital in button on the front but now I do and not only that I can get Dolby 2.0 and 5.1.

Excellent - thank you.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts