Cyrus cd player digital output

Keirik

New member
Dec 22, 2011
2
0
0
Hi all,

First post on here, so sorry it's a question.

I have a fairly old cd player -a Cyrus dad3 that I use purely as a transport feeding into a dacmagic, but the digital output (optical) has stopped working.

The player still works and the analog output works, and the optical link is still shining a nice red light out but all I'm getting is high quality silence.

Has anyone else with a Cyrus had this, or got any clues what the problem might be?

Thanks
 

kevinJ

New member
Nov 2, 2008
51
0
0
I don't know your cdp, but I also have a Dacmagic. So, lets get the easiest things out of the way first: have you tried a different input on the DM? Are there any tight bends in the optical cable you're using? Have you tried a different cable?
 

Crossie

New member
Aug 4, 2009
58
0
0
+1 KevinJ

If the red light is still shining out of the dAD3 optic output then the obvious culpret (and cheapest) is the cable. Even cheaper switch everything off remove the optic cable ,replace the cable and switch everything back on. A bit obvious but...sorry

Hope it works, if not a late present from Santa may be in order :)

Cheers
 

Keirik

New member
Dec 22, 2011
2
0
0
No problem with obvious suggestions guys :)

The cable is fine as is the input into the dacmagic, as I've swapped it between the cd player and the iPad dock I also use, and also swapped inputs on the dacmagic and everything works in every combination, except when the cd player is the source.

Id love a Christmas present to myself although it would more likely be a new phono stage but unfortunately mr taxman sent me rather a large bill which has put paid to that
 

Mooly

New member
Jun 10, 2011
1
0
0
Clutching at straws here,

Do you leave the Cyrus permanently powered up. If so maybe pull the plug for an hour or so and try again.

Are there any menus on the Cyrus relating to the SPDIF optical feed. Can it be turned on/off for example. Just because it's shining red doesn't mean there is data present.

You've tried the DAC with other sources. Any posiblity the DAC could be switched to a different sampling rate that just happened to coincide with the other sources and so making it look OK. I'm not familiar with the DAC at all so just thinking aloud on this one. Any menus on the Cyrus for data rate eg 44.1 or 48 khz.

Other than that and you might be looking at a problem with the TOSLINK feed/transmitter in the player.
 

Keirik

New member
Dec 22, 2011
2
0
0
The DaC selects bit rate automatically so don't think its that and the deck has been powered down and disconnected

Unfortunately I suspect it is the output :mad:
 

Mooly

New member
Jun 10, 2011
1
0
0
Perhaps a dealer would let you try the Cyrus on another DAC to be absolutely sure.

From all you have said it does seem to be a problem with the player.
 

Keirik

New member
Dec 22, 2011
2
0
0
Good idea, I need to take the sugden in for a service anyway and was planning to do some demoing, so seems a good place to start
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts