2nd denon 2310 still problems

admin_exported

New member
Aug 10, 2019
2,556
4
0
just tried my 2nd new 2310 and still wont work due to not supporting HDCP with shy+hd. can only think not compatable to my tompson sky+hd box. spoken to sky and they wont change it for another brand because they are blaming the denon. so gonna have to swap the denon for something else similar price. got £1000 max to spend please help!!!
 
A

Anonymous

Guest
You know that Sky+ doesn't output 5.1 sound except through the digital outputs e.g. coax or toslink?
 

proffski

New member
Dec 11, 2008
27
0
0
I'd try to get rid of the Thompson, I hate the brand! Have you tried telling SKY that you will shed the cntract if they do not? Sometimes they have been known to relent. The Denon is Sooooo Good!
 
A

Anonymous

Guest
i agree the denon is very good. so i rang sky again and didnt mention the denon this time and they said an engineer is being sent out monday. fingers crossed a samsung box might sort it.
 
A

Anonymous

Guest
Have you tried plugging the sky box into HDMI 1 or 2 on your receiver? Someone on another forum had the same problem and Denon advised them to do that, after which it worked fine.
 
A

Anonymous

Guest
yeah ive tried absolutely everything a million times just cant think of anything else. my second 2310 is supposedly the revised version sent especially from belgium!
 
A

Anonymous

Guest
I have an Amstrad Sky HD box and have arranged to go and pick up my new Denon 2310 soon. You have got me worried now though! Anyone else got the same set up?
emotion-7.gif
 
A

Anonymous

Guest
its all ok now swapped sky box today from tompson to pace and everything magically ok! pay sky 65 quid a month and they know it all eh
emotion-40.gif
 
A

Anonymous

Guest
Having replaced my entire system earlier this week which included the Denon AVR2310 and having run into the same issue as reported by others on this thread with Sky HD not functioning because of the HDCP issue and having had a frustrating conversation with Sky, I ended up speaking to Denon directly.

The issue does appear to be to do with the Thompson Sky HD box and they advised that I initially ensure that the firmware is up to date. However, I was not really happy with having to pay for a £65 call out for an engineer to look at the issue when there did not appear to be any guarantee that the issue would be resolved or that Sky would replace the box for another model.

That said I was provided with some invaluable advice being from Denon that resolved the issue. Essentially (using non-technical jargon) there are two HDMI boards. The Cable/Sat HDMI is on one board and I was advised to move the HDMI cable coming from the Sky HD box from this connection to a HDMI connection on the other board (I used the HDP connection as the DVD was taking my Sony Bu Ray player). This immediately solved the issue. I appreciate that this is not the "perfect" solution but a satisfactory one.
 

TRENDING THREADS