Rega Planar 3 - pitch variation

admin_exported

New member
Aug 10, 2019
2,556
4
0
Visit site
I've pulled an old Planar 3 out of the attic to transfer all my old vinyl to PC. I've noticed pitch change on a couple of the 33s I've done - a marked slowing down every now and again.

The drive band is really quite slack when I swap it to '33'. I guess this is the most likely cause and I'll change it if I can find someone who sells replacements. But if that doesn't fix it, is there anything else I should be looking at? Anyone else had the same?
 

Andrew Everard

New member
May 30, 2007
1,878
2
0
Visit site
Sounds like a slipping belt or a bearing that's a bit gummed up. Unlikely the motor will be on the blink. I'd contact your nearest Rega dealer for advice - you can find contact details on the Rega website. Changing the belt will be no problem as a DIY job, but the bearing is factory assembled with a special thick lubricant, so cleaning this out and replacing it may be a dealer service thing.
 
A

Anonymous

Guest
I had a Bush MTT1 turntable which did that alot. It also played all music about a semitone higher which was awfully annoying - I gave up on it in the end deciding that it wasn't the speed it was playing music at.
 
A

Anonymous

Guest
[quote user="Andrew Everard"] Sounds like a slipping belt or a bearing that's a bit gummed up. [/quote]

Thanks - I've ordered a replacement belt which I'll try first.

Having said that... while googling for the belt I came across a retro-fit motor upgrade for the Planar 3. Looks like it turns it into a direct drive(?)

Anyone got any experience? Specifically, as it's currently only got an on/off switch, can it still run at both 33 and 45 once converted. I will always need both.
 

gregory

New member
Sep 9, 2007
45
1
0
Visit site
it is a better toleranced motor and offers 33 and 45.regas are very reliable and i think changing the belt will improve your situation.when you hit the on button just give the platter a helping hand,rega motors are known to judder a bit at start up.i had mine for 15 odd years with no trouble but always gave it a bit of a nudge at start up.
 

TRENDING THREADS