Qobuz buffering problems-anyone else?

clothears

Well-known member
Nov 18, 2014
8
0
18,520
Interested to see if anyone else is experiencing frequent buffering when listening to Qobuz lately? (For the record I'm using an up to date Node 2i connected directly to my BT smart hub via ethernet and BT tell me I'm getting around 50mbps without issue, I certainly experience no problem streaming tv via wifi). As I was growing tired of the issue and all Bluesound support can seemingly offer is to advise me to reboot my player and router and tell me not to use wifi (I wasnt), I signed up to Amazon unlimited free trial. That works without issue but has poor functionality with the Node2i. So I'm pretty certain Qobuz are the problem-am I alone?
 

clothears

Well-known member
Nov 18, 2014
8
0
18,520
Thanks, I'm using a Bluesound Node 2i network player that uses its own native app with Qobuz (among others) and I'm not aware of any buffer settings or means of clearing caches etc. I can change (reduce) the streaming quality for Qobuz in the log on page but thats hardly the point of Qobuz, and as I said, Amazon works. Before I give up on Qobuz I just wondered if this is affecting many others?
 

Haselor

Member
Feb 10, 2022
1
0
20
I have been having the same problem for the last month. 70mbps Broadband, intermittent streaming.
I use Volumio 3 to stream Qobuz on 3 different Pi streamers. HiFi Berry, Digione, Allo Boss 2. All the same, Spotify works, is Qobuz broken?
 

clothears

Well-known member
Nov 18, 2014
8
0
18,520
I have had several contacts with both Qobuz and Bluesound over my issues. BT diagnostics tell me I have no problems with my broadband service and certainly I don't notice any other issues streaming netflix etc. Qobuz offered little advice other than to use their own app, which obviously is no help with a Bluesound player as the two are not compatible.
Bluesound went through my set-up, and wanted me to change my DNS lookup address. (I'm not very technical but I tried). BT home hubs don't allow such changes (Probably to stop idiots like me messing it up). They wanted to know if my ethernet cable was any good (I swapped to wi-fi-max indicated signal strength but it still buffered so back to the cable) and lots of reboots of router, node, factory resets, uninstalling the app etc etc.

Qobuz still won't play a whole album without stopping at least once.

Meanwhile, Amazon unlimited (with its awful Bluesound navigation and layout) just carries on working hour in hour out.

I pointed this out to Bluesound and they replied that I may want to consider changing streaming provider if Qobuz is unreliable...

I have 9 months Qobuz subsription remaining, which may prove to be wasted (lesson learned monthly only in future for streaming), and I may return the Bluesound Node2i as it is under extended warranty, to see if there is a particular Bluesound-Qobuz issue.

But yes to answer your question, as far as I can see, Qobuz has been broken since mid January.
 

clothears

Well-known member
Nov 18, 2014
8
0
18,520
I have been having the same problem for the last month. 70mbps Broadband, intermittent streaming.
I use Volumio 3 to stream Qobuz on 3 different Pi streamers. HiFi Berry, Digione, Allo Boss 2. All the same, Spotify works, is Qobuz broken?
Which Broadband provider do you use? I'm with BT (Fibre to the cabinet and within 500yds of cabinet) and getting around 50mbps I believe. I have read a lot about BT DNS servers being slow, and Bluesound advised me to change to Cloudflare or Google DNS, which my BT provided Home Hub router would not allow. I have (today) invested (£35!) in a TP link modem router and after playing around with the settings (in two places in the menu for some reason and not easy to find I thought) I have the Cloudflare DNS servers showing in the modem. On Friday I couldn't get through an album without buffering...so far it seems better but it's early days. I'll post back if this reolves the problem.

On another note, I had been listening to Amazon unlmited without problem. However, I'm convinced the quality does not sound as good as Qobuz (hence I'm keen to stay with Qobuz if I can). Listening to the latest Triosence album 'Giulia' in HR the Qobuz seems far more balanced and fluid. Amazon almost sounded (dare I say it!)...compressed by comparison.
I know its only 1s and 0s and they should be the same and yes I've been sceptical of those that say there's a difference, but there certainly is!
 

clothears

Well-known member
Nov 18, 2014
8
0
18,520
All my issues seem to have resolved as soon as I replaced the BT Smart Hub 2 modem-router with a Budget TP-Link unit. The ethernet socket indicator light on the Node 2i is now orange instead of green, which I believe indicates a higher bitrate capability (?). I changed to Cloudflare DNS (1.1.1.1) instead of the default BT DNS server, as this was recommended by Bluesound . I suspect it may be this that was causing connectivity issues with Qobuz (but somehow not with other services?), although it could have been the router itself. Either way, it is certainly worth swapping out the standard BT router and changing from BT DNS if you are suffering similar issues as I was.
 

Karlos12345

Member
Mar 7, 2022
1
0
20
Interested to see if anyone else is experiencing frequent buffering when listening to Qobuz lately? (For the record I'm using an up to date Node 2i connected directly to my BT smart hub via ethernet and BT tell me I'm getting around 50mbps without issue, I certainly experience no problem streaming tv via wifi). As I was growing tired of the issue and all Bluesound support can seemingly offer is to advise me to reboot my player and router and tell me not to use wifi (I wasnt), I signed up to Amazon unlimited free trial. That works without issue but has poor functionality with the Node2i. So I'm pretty certain Qobuz are the problem-am I alone
Same problem here. Running Qobuz through a VirginMedia Hub3. I have 220Mb service. One week into the free trial I get buffering issues with my Bluesound Node 2i. It runs Tidal perfectly and my 192 hi res files in my local library.
Gutted as the sound quality seems better than Tidal.
 

Moonfanatic

Member
Mar 25, 2022
4
2
20
Same problem here. Running Qobuz through a VirginMedia Hub3. I have 220Mb service. One week into the free trial I get buffering issues with my Bluesound Node 2i. It runs Tidal perfectly and my 192 hi res files in my local library.
Gutted as the sound quality seems better than Tidal.
I am experiencing the same problem with Qobuz. Stops randomly mid track! i am running with a wired connection from the BT smarthub router to the DAC. I recently took out a tidal subscription and it is rock solid so far. The advice I’ve had from Simaudio is that I need to change the DNS to Google or Cloudflare. So I am looking at a new router.
 

benp444

Member
Mar 27, 2022
3
0
20
Yes, same issue here. I am using a Linn Majik DSM (quite an old one). Linn support has said that the logs on their side show that the stream is dropping and the small buffer (as it is a old unit) is running out. That is why my Web Player has no problems (larger buffer which stores enough data to overcome the drop out.

Linn have stated that I switch DNS servers to Google DNS. But the BT Home Hub does not allow that.

Qobuz have stated that they changed their API " a couple of weeks ago" (dated 24/03/22), but I this may be a red herring.

Ive got a trial subscription on Tidal which has no issues so I guess I either buy a new router or switch to Tidal.
 

benp444

Member
Mar 27, 2022
3
0
20
Thanks, I'm using a Bluesound Node 2i network player that uses its own native app with Qobuz (among others) and I'm not aware of any buffer settings or means of clearing caches etc. I can change (reduce) the streaming quality for Qobuz in the log on page but thats hardly the point of Qobuz, and as I said, Amazon works. Before I give up on Qobuz I just wondered if this is affecting many others?
What ISP/Hub are you using?
 

benp444

Member
Mar 27, 2022
3
0
20
Just looking at this thread the common theme is that anyone who has mentioned their ISP and/or Hub state it is BT.
 

chrisbrain

Member
Oct 3, 2022
5
0
20
To re-iterate what others have said - try changing the DNS on your router to one of the big players (such as Google 8.8.8.8/8.8.4.4) rather then use the default DNS provided by your ISP - this solved my Node 2/Qobuz buffering issue.

I use Virginmedia and it is not possible to change the DNS on the provided hub so I had to buy a new router (TP-Link AX53) and put my hub into modem mode (there are other advantages of having a wi fi router so I felt I could justify the spend). The default setting on the TP-Lonk router is to use the ISP's DNS settings but this can be changed in the advanced settings using the web configuration page. After rebooting the router AND the Node 2 the buffering problem was solved.

I don't know why changing the DNS solves the problem - I thought the DNS would only be used for the initial connection but the buffering suggests the Node 2 is re-addressing the DNS server when part way through streaming which suggests a "feature" of either the Node 2 firmware for Qobuz connections or a feature of the Qobuz servers. It would be helpful if either Qobuz or Bluesound could publicise the feature to help their customers solve this problem because it really isn't obvious....
 

Moonfanatic

Member
Mar 25, 2022
4
2
20
To re-iterate what others have said - try changing the DNS on your router to one of the big players (such as Google 8.8.8.8/8.8.4.4) rather then use the default DNS provided by your ISP - this solved my Node 2/Qobuz buffering issue.

I use Virginmedia and it is not possible to change the DNS on the provided hub so I had to buy a new router (TP-Link AX53) and put my hub into modem mode (there are other advantages of having a wi fi router so I felt I could justify the spend). The default setting on the TP-Lonk router is to use the ISP's DNS settings but this can be changed in the advanced settings using the web configuration page. After rebooting the router AND the Node 2 the buffering problem was solved.

I don't know why changing the DNS solves the problem - I thought the DNS would only be used for the initial connection but the buffering suggests the Node 2 is re-addressing the DNS server when part way through streaming which suggests a "feature" of either the Node 2 firmware for Qobuz connections or a feature of the Qobuz servers. It would be helpful if either Qobuz or Bluesound could publicise the feature to help their customers solve this problem because it really isn't obvious....
I had to ditch my BT router is it didn’t allow a user defined DNS. I bought an ASUS router (very good) and changed the DNS to cloudflare (1.1.1.1). Qobuz has been absolutely rock solid ever since. No buffering. The other tip is to make sure your DAC/steamer has a permanent IP address assigned to it.
 
I had to ditch my BT router is it didn’t allow a user defined DNS. I bought an ASUS router (very good) and changed the DNS to cloudflare (1.1.1.1). Qobuz has been absolutely rock solid ever since. No buffering. The other tip is to make sure your DAC/steamer has a permanent IP address assigned to it.
Another tip might be to look at the date of the initial post...... The thread is a little bit aged.
 

chrisbrain

Member
Oct 3, 2022
5
0
20
To re-iterate what others have said - try changing the DNS on your router to one of the big players (such as Google 8.8.8.8/8.8.4.4) rather then use the default DNS provided by your ISP - this solved my Node 2/Qobuz buffering issue.

I use Virginmedia and it is not possible to change the DNS on the provided hub so I had to buy a new router (TP-Link AX53) and put my hub into modem mode (there are other advantages of having a wi fi router so I felt I could justify the spend). The default setting on the TP-Lonk router is to use the ISP's DNS settings but this can be changed in the advanced settings using the web configuration page. After rebooting the router AND the Node 2 the buffering problem was solved.

I don't know why changing the DNS solves the problem - I thought the DNS would only be used for the initial connection but the buffering suggests the Node 2 is re-addressing the DNS server when part way through streaming which suggests a "feature" of either the Node 2 firmware for Qobuz connections or a feature of the Qobuz servers. It would be helpful if either Qobuz or Bluesound could publicise the feature to help their customers solve this problem because it really isn't obvious....
By way of an update Bluesound support got back to say they do recommend changing the DNS from your ISP's DNS to solve this issue so fair play. However not all ISPs allow this with their supplied modem/router (eg Virginmedia) so the solution may mean buying a separate router to try out this solution.
 

chrisbrain

Member
Oct 3, 2022
5
0
20
Another tip might be to look at the date of the initial post...... The thread is a little bit aged.
Yes but the problem is still on-going and the solution isn't at all obvious so worthy of an update to confirm the advice is still relevant?
 

visu

Member
Oct 6, 2022
1
0
20
I have had several contacts with both Qobuz and Bluesound over my issues. BT diagnostics tell me I have no problems with my broadband service and certainly I don't notice any other issues streaming netflix etc. Qobuz offered little advice other than to use their own app, which obviously is no help with a Bluesound player as the two are not compatible.
Bluesound went through my set-up, and wanted me to change my DNS lookup address. (I'm not very technical but I tried). BT home hubs don't allow such changes (Probably to stop idiots like me messing it up). They wanted to know if my ethernet cable was any good (I swapped to wi-fi-max indicated signal strength but it still buffered so back to the cable) and lots of reboots of router, node, factory resets, uninstalling the app etc etc.

Qobuz still won't play a whole album without stopping at least once.

Meanwhile, Amazon unlimited (with its awful Bluesound navigation and layout) just carries on working hour in hour out.

I pointed this out to Bluesound and they replied that I may want to consider changing streaming provider if Qobuz is unreliable...

I have 9 months Qobuz subsription remaining, which may prove to be wasted (lesson learned monthly only in future for streaming), and I may return the Bluesound Node2i as it is under extended warranty, to see if there is a particular Bluesound-Qobuz issue.

But yes to answer your question, as far as I can see, Qobuz has been broken since mid January.
Not just me then! I have a similar issue streaming hi res albums on the Mac client but not on my iPhone (where I stream at CD quality)
 

chrisbrain

Member
Oct 3, 2022
5
0
20
Not just me then! I have a similar issue streaming hi res albums on the Mac client but not on my iPhone (where I stream at CD quality)
As per my earlier reply for those encountering HR streaming issues on Qobuz and Bluesound the solution appears to be to change the primary/secondary DNS to something like 1.1.1.1/1.0.0.1 but this isn't possible with some ISP supplied kit (such as BT and Virginmedia) - you need to buy a separate router and run the ISP kit in modem mode. It's relatively easy to do and a router will improve wifi reception, run faster and will provide several other useful features and you can get a decent router for less than £100 (I went for the TP-Link AC53).

It looks to me like a problem with the Bluesound firmware and how it connects to Qobuz - as far as I can make out if you use the Qobuz app there is no problem streaming HR content which seems to imply there is no issue at with the Qobuz servers. From the little I know about DNS I really don't understand why this should work but it does.

I've stuck with Qobuz because I like their content and the quality (when it does work) is excellent. And I can justify the spend on the router as it improves my internet connection as well as solving this issue.
 

Coxon72

Member
Oct 22, 2022
2
0
20
I Have been having this same issue with qobuz via a Project Stream box S2 Ultra, with Virgin 300bps plus, Originally hub 3 but upgraded to hub4 but didn't make any difference. Looks the the advice is to buy a better router and put virgin hub 4 in modem mode. I have been on trial with Tidal without music stopping and moving on to the next track regularly.
 

chrisbrain

Member
Oct 3, 2022
5
0
20
I Have been having this same issue with qobuz via a Project Stream box S2 Ultra, with Virgin 300bps plus, Originally hub 3 but upgraded to hub4 but didn't make any difference. Looks the the advice is to buy a better router and put virgin hub 4 in modem mode. I have been on trial with Tidal without music stopping and moving on to the next track regularly.
The solution appears to be to change the DNS address - just getting a router and not changing the DNS will not solve the problem - in fact you only need the router because the devices provided by your ISP probably won't allow you to do this. As a bonus you should get a better WiFi signal by getting a dedicated router so arguably worth the expense anyway.
 

ASK THE COMMUNITY

TRENDING THREADS