Problem with Amplifier

admin_exported

New member
Aug 10, 2019
2,556
3
0
Hello, have just bought a Marantz PM6003 Amplifier, the problem is that it keeps going into standby mode, sometimes after a few minutes and othertimes when I turn the volume up. Has anyone experianced a similar problem and if so do you know a solution, otherwise I'll be lugging it back to the shop.
 
A

Anonymous

Guest
i would check your speaker cables are connected properly ie. no stray wires touching things they arent supposed to. if everything is fine there and the problem is still happening then take it back to the shop. or better still ring the shop and explain your situation, maybe they will have a solution.
 
T

the record spot

Guest
If you've just bought it, check the wires as suggested, though if this is a banana plug connection, there shouldn't be too many issues here. If you bought it within the last 28 days, ask for a brand new replacement amp (to which you are entitled). Outwith this period, it should be fixed under warranty (assuming 12 or 24 months as appropriate). Either way, forget the "solution", the only one here is replacement or repair assuming you haven't made a basic error or have a mains power problem.
 

rardhian

New member
Sep 22, 2010
6
0
0
Could've been bad electric voltage? Try checking your power outlet voltage. If it perfectly matches your amp, I'd go with replacement as soon as possible. Otherwise, I'd try adding some voltage stabilizer.

DacMagic shuts off on any voltage lesser than 180V. And some amps do had darker and warmer sound when powered by lesser required voltage
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts