Pro-ject debut 3 and linn adikt

admin_exported

New member
Aug 10, 2019
2,556
3
0
Ok so i have a project debut 3 turntable with the standard ortofon cartridge, but i also have a spare linn adikt kicking about. the reason that i've not fitted it is that when i do i get really bad mains hum coming through the speakers. does anyone have any suggestions as to what could be causing this? everythings earthed (or at least the cables are attached, i cant check if there is a break). and there's no problem when the standard cart is fittted. it's kind of a shame to have the thing sitting about not being used.
 

John Duncan

Well-known member
Jan 8, 2008
2,027
13
19,695
Right, well it depends on how the grounding works in the cartridge I think, but have you tried not grounding it? I had this issue with my Revolver/Arcam years ago, and found that the way to deal with it was to not ground the 'table - I think this had something to do with the way that Rega arms are wired, but not sure.
 

fatboyslimfast

Well-known member
Jan 10, 2008
158
0
18,590
I had a similar problem with my Rega arm, but only using a Rega Bias - it turned out to be a dodgy earth connection that wasn't sitting on the cartridge pin correctly... might be an idea (if you have one) to use a multimeter to check whether the cartridge pin (once connected) is a good connection to the ground on the phono cable...
 
A

Anonymous

Guest
I *think* last time i tried it i tried both the earth commected to the pp2 and left loose, but will try again. as an aside, i did notice that i had to change the polarity (or something) of my sub when moving back to this flat as otherwise it gave of major hums. maybe my cartridge will work in this flat.... or maybe i need one of those tachiama mains filters.

cheers for the advice, i'll give it a go.
 
A

Anonymous

Guest
well i just got around to doing this as the g/f is now back home due to uni starting again. (only about 30 miles but it means i get to listen to music again).

Still getting a hum, i even unscrewed the earth on the arm as well as the one attached to the phonostage. I may pick up a volt meter at some point but knowing me thats a long way off!

Maybe i'll get to check it on a different t/t or maybe it'll just sit in the cupboard till i upgrade and try again.
 

ASK THE COMMUNITY

TRENDING THREADS