Marantz MCR603 - anyone else experiencing problems?

admin_exported

New member
Aug 10, 2019
2,556
3
0
The technology of the MCR603 should be really impressive but unfortunately mine appears to be full of faults: The
first unit I had froze after two days and I had to return it. The replacement unit has faults with the ipod input; sometimes it recognises my ipod, other times it doesn't, sometimes it plays the ipod, other times it doesn't! The DAB presets appear and disappear. I have upgraded to the airplay which works well but has an annoying glitch of ramping up the volume every time I
connect. Is anyone else experiencing this or able to offer an explanation?
 
A

Anonymous

Guest
Hi

I've no problems with the MCR603 so far - everything works like a charm, but it's only 5 days old ;)

I think the volume is set by Itunes, when using Airplay. You can use the slider next to the play/ship buttons to control, the volume on the Marantz.

The Ipod function, I'll test in the next couple of days...
 
A

Anonymous

Guest
Hi,

Loving the MCR603. I have it connected to a pair of KefQ300 and it sounds great.

It is proving to be a pain to set up onto my network. After a while, the whole network drops and my router needs to be re-boot. It works again for around 30 mins and it happens again.

I have a few airport express units scattered around the house, I thought it was an IP conflict of some description, but it does not appear to be.

I am thinking it might be just as easy to get another airport express and then use the optical in on the unit, but after paying for the airplay upgrade, I want it to work!

sorry I can't help you out LSD, but I thought I would share - any help anyone can throw my way would be great!

Cheers,

Mike
 
A

Anonymous

Guest
I'm having problems with mine:

1) system sometimes locks up when opening CD draw.

2) system sometimes locks up when changing volume.

3) every 20 min or so internet radio states "server disconnected" (ok on laptop running same station through Vtuner) turn off/on again and is ok for another 20mins.
 
A

Anonymous

Guest
chebby - thanks a million.

I have played around with my firewall settings - seems to be working at the moment - but no idea for how long.....

hopefully no need to call them in the morning!

Cheers,

Mike
 
A

Anonymous

Guest
Mine has frozen twice when I've been listening to either DAB or internet radio; means having to switch off at the mains and then re-boot etc...

I've done the firmware upgrade tonight though so will have to see if that sorts it

Other than that I'm thoroughly enjoying the system
 

chebby

Well-known member
Jun 2, 2008
1,245
11
19,195
Mine has been trouble free so far. I plugged in the ethernet, before first powering it on, and it did all the firmware updates etc. before anything else.

No freeze ups at all.

I did call their support number (the one I gave above) after the AirPlay download because - despite seeing the download happen - I didn't know how to check it at first and wondered if my registration number was wrongly entered on the Marantz purchase screens. It was ok.

(I had to power off my iPhone and power it back on before I got the AirPlay symbol.)

Otherwise good so far.
 

Frank Harvey

Well-known member
Jun 27, 2008
567
0
18,890
Unfortunately, anything that's software based is going to be prone to locking up - a reboot should sort this. I'm not saying it's acceptable, but some investigation is needed to find out the cause of the locking up. Like most things nowadays, there will be side effects' to updates etc, and many things will be ironed out during following software updates. Anyone with issues should speak to the manufacturer to let them know of their issues, and to find out of it's a known fault that is being looked at.
When we initially set up AirPlay on our 603, the volume jumped up to full when connecting an iPod - it jumped up to half way when connecting an iPad - but we've had no issues like that since.
 
A

Anonymous

Guest
I've downloaded AirPlay onto my system now but I've no AirPlay icon on iTunes; any ideas?
 

chebby

Well-known member
Jun 2, 2008
1,245
11
19,195
hifilover1979 said:
I've downloaded AirPlay onto my system now but I've no AirPlay icon on iTunes; any ideas?
Power off your Marantz. Power back on again. (Check the words 'Marantz M-CR603 Upgrade' appears briefly in the display when it comes up. That shows the upgrade is ok.)

Power off/on your iPhone too.

Ensure iTunes on your computer/software on your iPhone are the correct release for AirPlay compatibility

If you still have problems then call the support number I gave you earlier.
 

chebby

Well-known member
Jun 2, 2008
1,245
11
19,195
marineman said:
Dealer is sending replacement
Did you have the ethernet cable connected when the unit was first powered up? Did you allow the firmware downloads and installs to complete before using it?
 
A

Anonymous

Guest
chebby said:
hifilover1979 said:
I've downloaded AirPlay onto my system now but I've no AirPlay icon on iTunes; any ideas?
Power off your Marantz. Power back on again. (Check the words 'Marantz M-CR603 Upgrade' appears briefly in the display when it comes up. That shows the upgrade is ok.)

Power off/on your iPhone too.

Ensure iTunes on your computer/software on your iPhone are the correct release for AirPlay compatibility

If you still have problems then call the support number I gave you earlier.
Marantz powered off and on when I did the AirPlay upgrade; 'Marantz CR603 upgrade' appeared as it said it should

iPhone shut down and rebooted as advised

iPhone 4 and iTunes (version 10.2.1) are all up to date but still no AirPlay

Will give that guy a ring and see whats said
 
A

Anonymous

Guest
Hi

I think the MCR603 is great, but it has some small software bugs.

The volume display sometimes hangs, and the vtuner is very slow on cold start - I hope the vtuner gets faster...
 
A

Anonymous

Guest
My MCR603 has hung 3 times in the last month. I mostly use it for listening to DAB and this is when it happens. As other folks have said, pulling the plug out from the mains was necessary to restart it. Can't figure out if it's anything in particular I'm doing that causes it or if it's just random. According to the software update I have the latest version.

I've also being having problems with Airplay. Installing it was pretty simple (unlike my Denon amp which was a royal pain). However, it takes a long time after turning on the amp (2-3 minutes) before it appears on my iPhone or iPad as an Airplay destination. Other Airplay speakers I have around the house appear in seconds. When I try and 'send' audio to the Marantz nothing at all happens for about a minute, then the hifi switches itself over to Airplay mode. No sound comes out although the iPhone still plays the video happily. After another minute or so I'm usually sick of waiting and then I start fiddling with the iPhone, playing a different track. It's ususally at that point the sound starts coming out of the Marantz. Once it starts, it works OK... it just takes a lot of messing around and waiting for anything to happen.

Airplay works fine on my Denon amp, through my Airport Express base station and my in-car system, so I don't think it's my iPhone or my wifi network. The Marantz is connected through a Powerline adapter and internet radio loads relatively fast, so I'm not sure it's that either.

Anyone else having a similar problem with the Airplay software?

Cheers

Jon
 

DIB

Well-known member
May 21, 2009
156
30
18,620
I have been playing my new M-CR603 constantly for the last 6 days and I have no faults whatsoever I'm pleased to report.

It has not froze once,and the initial set-up with firmware updates went off with no hick-ups at all.

As mentioned above, if I was being very very picky then the internet radio when first switched on from a cold start takes over a minute to get running, but that is very minor. I tend to put the kettle on and make a brew whilst thats happening


I do not use i-tunes, airplay or any other Apple related products so cannot comment on those.

I cannot fault mine whatsoever so far. I love it.

.
 

pwiles1968

New member
Mar 22, 2009
153
0
0
Had a full volume issue the first time I started with air play and sometimes when I turn off the Marantz in iTunes, iTunes crashes.

But other than those minor issues It seems to be fine.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts