KEF LS50 Wireless II - various questions

Page 2 - Seeking answers? Join the What HiFi community: the world's leading independent guide to buying and owning hi-fi and home entertainment products.

2xcess

Well-known member
Mar 7, 2011
22
9
18,525
Dear All,
please let me ask some questions:
- Both the speakers do a electronical scratch (low noise level) while turning on/off and while changing source. Do the speaker work properly?
- The KEF Connect App seems to lose connection with Amazon. Did anybody experience this problem, too?
- Does anybody know if there is a difference in resolution between Amazon on the one and Spotify, Tidal, Deezer on the other hand?
- Does anybody know which resoultion is streamed by Amazon (e.g. if there is a version of a certain song in 24 bit/96 kHz, does Amazon provide this version/resolution)? I chose the AmazonHD- contract on my Windows App) - so Amazon should provide the speakers with the highest resolution available, right?

Thanks for any Idea

Chris
Chris,

I took delivery of some titanium grey LS50 wireless IIs about 10 days ago (titanium grey weren't in stock so had to wait a month before delivery).
A generally very good experience is being blighted by exactly the problems you are seeing. A crackle on switching on and sources (that I can tolerate) but I am also getting the occasional glitches and/drop outs during playback. I get the same from various sources: Tidal Hi-Fi, both using the KEF app and Tidal connect, Amazon Music HD in the KEF app and also from my flac NAS collection (16 and 24 bit). I've tried using the speakers in wireless paired mode and using the supplied ethernet cable and a cat 7 cable. Internet bandwidth isn't the issue the LS50s and my mobile have QoS priority and only take 2Mbps at most. Wireless is provided by a 3 node Deco M9+ mesh and is in excess of 650Mbps at their location on the 5GHz channel. Other than connecting them directly to the main node with an Ethernet cable as a final check (makes them being wireless pointless though) I'm pretty sure it's not WiFi or internet bandwidth related. Have you had any luck with this issue before I contact KEF for support myself?

Steve
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
Chris,

I took delivery of some titanium grey LS50 wireless IIs about 10 days ago (titanium grey weren't in stock so had to wait a month before delivery).
A generally very good experience is being blighted by exactly the problems you are seeing. A crackle on switching on and sources (that I can tolerate) but I am also getting the occasional glitches and/drop outs during playback. I get the same from various sources: Tidal Hi-Fi, both using the KEF app and Tidal connect, Amazon Music HD in the KEF app and also from my flac NAS collection (16 and 24 bit). I've tried using the speakers in wireless paired mode and using the supplied ethernet cable and a cat 7 cable. Internet bandwidth isn't the issue the LS50s and my mobile have QoS priority and only take 2Mbps at most. Wireless is provided by a 3 node Deco M9+ mesh and is in excess of 650Mbps at their location on the 5GHz channel. Other than connecting them directly to the main node with an Ethernet cable as a final check (makes them being wireless pointless though) I'm pretty sure it's not WiFi or internet bandwidth related. Have you had any luck with this issue before I contact KEF for support myself?

Steve
Dear Steve,

I had no further conversation with the KEF customer service on that topic but handed them in to the retailer who checked them (Amazon Music HD, 24 hours, without any problem - as he said).

Since then I seldomly notice any glitches. So, keep your fingers crossed.

I change my wireless setup by removing an obviously useless repeater - since that point it is getting much better. My recent setup: Fritz 6591 cable, Fritz Repeater 310. This might have been the reason having the drop outs. Considering the drop outs, I also had some issues with Amazon echos.

On the other hand, I sometimes experienced some glitches also with my CD Player (coax connected - NAD C 525 BEE).

So, I´m going to remove possible errors in my place, foremost the current, strengthen the WLAN-connectivity and so on.

Kind regards

Chris
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
I have the Amazon app on my iPhone. When I search for an artist (eg Dave Grusin) his albums are pulled up. Under each album is a notation, ie, either HD or UHD. You choose the album to play and get the resolution indicated.
HI,

that´s correct, but you can´t get any information on the resolution using the KEF app only.

Chris
 

gregvet

Well-known member
Dec 24, 2008
128
10
18,595
I’m not sure how you are sending the music from Amazon on your iphone to the LS50’s, but if it is over airplay, the maximum bit rate is limited to cd quality, even if the original file is UHD. In order to get the UHD files to the speakers in the original format I believe you would need to be sending them from a pc/Mac via optical, or something similar
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
[/QUOTE]
I’m not sure how you are sending the music from Amazon on your iphone to the LS50’s, but if it is over airplay, the maximum bit rate is limited to cd quality, even if the original file is UHD. In order to get the UHD files to the speakers in the original format I believe you would need to be sending them from a pc/Mac via optical, or something similar
Thanks,

the KEF App communicates directly with amazon streaming, doesn't it?

So airplay is not involved. (??)

Regards

Chris
 

2xcess

Well-known member
Mar 7, 2011
22
9
18,525
Dear Steve,

I had no further conversation with the KEF customer service on that topic but handed them in to the retailer who checked them (Amazon Music HD, 24 hours, without any problem - as he said).

Since then I seldomly notice any glitches. So, keep your fingers crossed.

I change my wireless setup by removing an obviously useless repeater - since that point it is getting much better. My recent setup: Fritz 6591 cable, Fritz Repeater 310. This might have been the reason having the drop outs. Considering the drop outs, I also had some issues with Amazon echos.

On the other hand, I sometimes experienced some glitches also with my CD Player (coax connected - NAD C 525 BEE).

So, I´m going to remove possible errors in my place, foremost the current, strengthen the WLAN-connectivity and so on.

Kind regards

Chris
Thanks for the reply and update. The fact that you have seen an improvement gives me hope of a solution. I guess I will try connecting the LS50 W2 primary speaker to the main mesh node by ethernet cable to eliminate the chance that it is WiFi related. The tri-band Mesh system I have installed uses one of the 5GHz channels for backhaul (unless nodes are connected via ethernet) so I wonder, grasping at straws, if the backhaul channel is resulting in interference with the 5GHz channel used for streaming data transfer.

I'll contact KEF to see if they have any ideas, they do say in LS50 W2 user manual that they've tested the LS50 W2 with some mesh systems and that the ones they have tried work well.

Steve.
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
Thanks for the reply and update. The fact that you have seen an improvement gives me hope of a solution. I guess I will try connecting the LS50 W2 primary speaker to the main mesh node by ethernet cable to eliminate the chance that it is WiFi related. The tri-band Mesh system I have installed uses one of the 5GHz channels for backhaul (unless nodes are connected via ethernet) so I wonder, grasping at straws, if the backhaul channel is resulting in interference with the 5GHz channel used for streaming data transfer.

I'll contact KEF to see if they have any ideas, they do say in LS50 W2 user manual that they've tested the LS50 W2 with some mesh systems and that the ones they have tried work well.

Steve.
Dear Steve,

thanks for your reply.

I just found out (or guess) that the real Problem is amazon HD (doesn´t work properly while the trial version of TIDAL works at the same time - i'm just running up for an long term test).

Please keep me informed on your progress.

By the way: The mesh components are: ritz 6591 cable, Fritz Repeater 3000

Chris
 

manicm

Well-known member
May 1, 2008
1,078
263
19,570
If you‘re using Tidal through the Kef app, you will be using Tidal Connect, in a very similar way to Spotify.

Whichever service you use, make sure in Tidal for example, you specifically connect the app to the KEF speaker.
 

Anssi K

Member
Dec 28, 2020
3
0
20
HDMI does have its issues, currently not working with my LG OLED and waiting for a software update to correct it
I have a 2017 model year LG oled and I haven’t made the sound heard through hdmi-Arc. Have you been in contact with Kef support about this? Are you waiting for an update on your TV or speakers?
 

gregvet

Well-known member
Dec 24, 2008
128
10
18,595

Thanks,

the KEF App communicates directly with amazon streaming, doesn't it?

So airplay is not involved. (??)

Regards

Chris
[/QUOTE]
I haven’t used the Amazon music service so I can’t say for sure. If that’s how it works (similar to Spotify connect or tidal connect) then maybe. However if the phone is sending the files to the speakers, my understanding is that it is limited by apple to cd quality, no higher. Whether that is locally stored files or streamed from the cloud via your phone should make no difference

again, only my understanding and more than happy to be corrected 😀
 

2xcess

Well-known member
Mar 7, 2011
22
9
18,525
Dear Steve,

thanks for your reply.

I just found out (or guess) that the real Problem is amazon HD (doesn´t work properly while the trial version of TIDAL works at the same time - i'm just running up for an long term test).

Please keep me informed on your progress.

By the way: The mesh components are: ritz 6591 cable, Fritz Repeater 3000

Chris
Issue resolved.

An update - thanks to Chris for making me consider the Wi-Fi again. I decided to force the LS50 W2s to connect to the primary mesh node, the 5GHz signal is weaker than via node they were connected to but, line of sight, the LS50 W2 primary speaker is closer to the primary mesh node than that secondary mesh node is to the primary. Throughout yesterday evening and today I have not had one 'glitch' or dropout. None: from any source. I have no idea why this has turned out to be the case, video streaming, file transfer, Sky, Netflix, Amazon video etc are all running fault free off that secondary node (there's a 3rd upstairs and again no issues with video streaming etc). I can only conclude that the KEF LS50 W2s are very sensitive to WiFi conditions, perhaps the secondary nodes 'chatter' to the primary, temporarily interrupting the data stream and the LS50 W2s do little or no buffering? Source resolution made no difference to the 'glitches' and dropouts, either frequency or duration.
Open to ideas! Thanks again to Chris for making me try something I thought would not work.....

For future reference, in case anyone else has this issue, I am using a 3 node TP-LINK Deco M9+ mesh. To hold the LS50 W2s to the primary node I have switched off 'Mesh Technolgy' in the Deco app for the LS50 W2s, this prevents the LS50 W2s from roaming to another node with a stronger signal once connected to the primary.

Steve.
 
  • Like
Reactions: jjbomber

Terence J

Member
Jan 20, 2021
8
0
20
Although we are very pleased with the audio quality of the LS50 Wireless 2s, we have still been unable to connect our Samsung Q 7 via HDMI ( since November 2020). While we have sound via the optical output, it is totally unacceptable that there is no published fix from KEF on the HDMI.These speakers are supposed to premium and yet their input's dont work. It literally took over a week going back and forth trying to connect the new KEFS when we received them - 3 months later - no fix for HDMI?? As another FYI - we were unable to hardwire a SUB into these speakers - really at a loss - we are looking to add a SUB to the mix but have no confidence that a product will be able to connect.
Quite frankly - would send them back if they would accept them.
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
Dear terence,

did you try the follwing steps (users guide):

The speakers are compatible with HDMI eARC (enhanced Audio Return Channel)
output from your TV for integrated control through a single HDMI cable. The speakers
must always be first connected to your local network before HDMI connection.
The speakers are also backward compatible with ARC and HDMI CEC. HDMI CEC
allows the use of the television remote control to adjust the volume of the speakers.

Samsung:
Refer to the user manual of your TV for details as manufacturers may name
the HDMI connections differently (e.g. Anynet+ for Samsung, Simplink for
LG). Make sure the digital audio output setting for the television is set to
PCM (not Dolby, Bitstream, Auto or similar).#


Regards

Chris
 

Terence J

Member
Jan 20, 2021
8
0
20
Dear terence,

did you try the follwing steps (users guide):

The speakers are compatible with HDMI eARC (enhanced Audio Return Channel)
output from your TV for integrated control through a single HDMI cable. The speakers
must always be first connected to your local network before HDMI connection.
The speakers are also backward compatible with ARC and HDMI CEC. HDMI CEC
allows the use of the television remote control to adjust the volume of the speakers.

Samsung:
Refer to the user manual of your TV for details as manufacturers may name
the HDMI connections differently (e.g. Anynet+ for Samsung, Simplink for
LG). Make sure the digital audio output setting for the television is set to
PCM (not Dolby, Bitstream, Auto or similar).#


Regards

Chris
Thanks Chris, we walked through all of the above with KEF Support, there is a specific arc HDMI output on the TV ( plugged in ), The TV settings are HDMI CEC ( remote doesn't control speakers - still have to use KEF app or the remote that came with speakers, Anynet+ is on, Digital audio is set to PCM. "Maybe" they weren't connected to the network BEFORE plugged in (?) - will try disconnecting HDMI and try again. The larger concern is their inability to Troubleshoot and ultimately fix ( we did walk through the manual ). The SUB simply did not work - no solution? Hardwired into LTE on SUB
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
Dear Terence,

have you already updatet the speakers to firmware version 1.3?

It is available now and "to be said" is going to improve hdmi-interoperability.

Regards

Chris
 

Terence J

Member
Jan 20, 2021
8
0
20
Thanks again - yes the Version is 1.3.
Maybe there is an issue with certain TVs?...No idea .
Tried your earlier remedy and it did not work. Bluetooth doesn't work. HDMI doesn't work but Optical does ??
Again - expensive investment to have so many options NOT work.....at the very least KEFZ should forewarn purchasers that their equipment is not compatible with "x,y,z" equipment.
We have given many opportunity for them to provide support ( literally hours of frustration spent originally checking WIFI, then TV, then SUB ).
In terms of connectivity, we have a Sonos One , Sonos 5, Apple HomePod, 2xApple TVS ALL of which hook up seamlessly.
After seeing that other people are experiencing similar issues today , I will be reaching back again tomorrow to their "Support" line.
I really appreciate you input,....should we be stuck with the purchase and issues what SUB would you recommend that would have the best "chance" of actually connecting?
 

Anssi K

Member
Dec 28, 2020
3
0
20
I also have problems connecting the speakers to the TV via HDMI. Television is a few years old LG Oled. The software version of the speakers is 1.3. I've tried all television settings, as well as to comply with the instructions in the manual for the speakers, as well as experimented with several types of HDMI cables. KEF support has not been able to help. If there are several of these cases, the fault must be in the speakers. Hopefully KEF will resolve the matter soon. The product is not cheap and this needs to be fixed.
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
Thanks again - yes the Version is 1.3.
Maybe there is an issue with certain TVs?...No idea .
Tried your earlier remedy and it did not work. Bluetooth doesn't work. HDMI doesn't work but Optical does ??
Again - expensive investment to have so many options NOT work.....at the very least KEFZ should forewarn purchasers that their equipment is not compatible with "x,y,z" equipment.
We have given many opportunity for them to provide support ( literally hours of frustration spent originally checking WIFI, then TV, then SUB ).
In terms of connectivity, we have a Sonos One , Sonos 5, Apple HomePod, 2xApple TVS ALL of which hook up seamlessly.
After seeing that other people are experiencing similar issues today , I will be reaching back again tomorrow to their "Support" line.
I really appreciate you input,....should we be stuck with the purchase and issues what SUB would you recommend that would have the best "chance" of actually connecting?
Sorry, I do not have any idea on a sub. I do ot use any.
 

Terence J

Member
Jan 20, 2021
8
0
20
I also have problems connecting the speakers to the TV via HDMI. Television is a few years old LG Oled. The software version of the speakers is 1.3. I've tried all television settings, as well as to comply with the instructions in the manual for the speakers, as well as experimented with several types of HDMI cables. KEF support has not been able to help. If there are several of these cases, the fault must be in the speakers. Hopefully KEF will resolve the matter soon. The product is not cheap and this needs to be fixed.
Good morning,
I would agree that it is their responsibility to fix, however unlikely they accept it. These are two examples from two different tv manufacturers. Our television is three years old.
If we were aware of any/all of the issues that we have had , we would would not have purchased.
If they are heading down a wireless road they should hire from companies that have figured it out.
Anyone who has purchased thus far, can only hope that their issues can be fixed with a firm upgrade.
Although they provide great sound, it does not offset the frustration - would return today for money back.
 

ChrisK1976

Member
Nov 8, 2020
12
0
20
Dear all,

back from serious tests :)-)), the KEF are getting better and better. The Scratches seemed to be due to the WLAN-Connection - which obviously was not that good. After I connected them to the LAN, 99,9% of the former problems vanished.

I do not have any problem connecting them to the TV either (Panasonic eARC).

Regards

Chris
 

RoA

Well-known member
Feb 11, 2021
283
143
570
Dear all,

back from serious tests :)-)), the KEF are getting better and better. The Scratches seemed to be due to the WLAN-Connection - which obviously was not that good. After I connected them to the LAN, 99,9% of the former problems vanished.

I do not have any problem connecting them to the TV either (Panasonic eARC).

Regards

Chris
Lovely speakers. Rich, powerful sound and relaxing to listen to.
 

2xcess

Well-known member
Mar 7, 2011
22
9
18,525
I should update on the LS50 wireless II issues that I had early in my ownership. Basically, they've performed faultlessly for over a month now. Wireless connection to my WiFi mesh and wireless connection between speakers is stable (although when first turned on the LS50s seem to occasionally go through a phase of establishing a stable wireless connection between speakers - connecting to the secondary, then dropping the secondary then connecting again, as if they are searching for on interference-free channel). Now that I'm comfortable that the speaker to speaker wireless connection is working as it should I've gone back to a wired Ethernet connection between speakers. Connection to the Mesh network remains wireless.

Connection to the REL T5i sub has always been perfect so no complaints there.

FWIW firmware update V1.5 came out yesterday morning (8th March). It's not added much for me, as fortunately, my LS50s are working fine, but it might address some issues others are seeing; perhaps?

Steve.
 
Last edited:

RoA

Well-known member
Feb 11, 2021
283
143
570
Yes, KEF have made inroads with regards to their software. There are still things I'd like to see but I am largely happy with the user experience.

I have that nagging urge though to try B&W's Foundation Duo. Twice I have chosen the colour and twice I have stopped just before pressing the button.
 

ASK THE COMMUNITY

TRENDING THREADS