Hum

True Blue

New member
Oct 18, 2008
185
0
0
Went into my listening room tonight and could hear "something". Put my ears to the speakers, a definate hum from both.

Then put my ear next to my new hicap and it too is humming.................

Switched all off tonight, will make and break all connectors / tidy up cabling tomorrow.

Any other ideas??
 

True Blue

New member
Oct 18, 2008
185
0
0
Right quick update, this one has freaked me out seeing as I have a dedicated radial cct to the HIFI.

When I switched off my Subwoofer (seperate room, seperate cct), the hum in the speakers went away..............................................????????????????????????????????????????????????????

However the HI CAP has still got a transformer lamination hum, which is very low level and expected.

Still unplug and replug all connections (and dust) tomorrow.
 

RCduck7

Well-known member
Aug 18, 2007
78
15
18,545
So, the subwoofer is causing the hum?? Propably a ground loop. Try disconnecting the grounding of the sub.

I had this problem to with my power amps.
 

True Blue

New member
Oct 18, 2008
185
0
0
All sorted.

Removed ALL my AV equipment plug cases and checked all earth connections.........loose couple found.

Stripped down the HIFI, dusted, cleaned, checked tightness on all electrical plug connections, reassembled in a slightly different configuration, the hicap is no longer on the floor next to my NAPSC, it has its own shelf now. A bit of cable dressing, the use of some cable ties and

Et voila!! All powered on and not a sound, perfect.

Now time to chill and listen to music
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts