Faulty Roksan Kandy 3 amp

paulsue38

New member
Mar 26, 2010
55
0
0
I have lost sound from all sources on my Kandy 3 amp (original version not the new one). I suspect that the amp has detected a fault and the protection has been activated. I have power lights for all sources, (red and not yellow) for those that know this model. The volume control works with the remote control.
I found the fuse under the power lead which looks ok and I suspect this is the power fuse; as I appear to have ‘power’ this does not seem to be the problem? I have opened up the machine (not under warranty) to try and locate the fuse for this but can’t find any. Is there anyone out there can advise?
Best wishes
Paul
 
A

Anonymous

Guest
If I were you I would just send it back to Roksan so they can repair it. Unless you actually know what you are looking for/doing then I'd leave the tinkering to the experts.
 

paulsue38

New member
Mar 26, 2010
55
0
0
Thanks for the reply. I have located two protection fuses that have blown. I have taken to a local electronic surgery to repair (they are soldered in) . Hoping that nothing else has gone. I figured that given the weight of the amp it would have been over £40 to send and return and that it may be more cost effective to repiar locally. It is out of warranty so worries about this. In the meantime i have borrowed an old A/R Cambridge A60 from my brother. It's great easily driven and lovely midrange!
Paul
 
A

Anonymous

Guest
Yeah, I think that is for the best. I understand where you are coming from in terms of shipping it back to Roksan - it's a heavy brute.

I had a kandy mk3 liii and it developed a fault within a few months of owning it. Audio only coming out of one channel then went crazy (sounds sporadically coming out of different channels at very high volume) when I tried to adjust volume. I've read about quite a few cases relating to issues with that particular amp.

Very happy with my Caspian though. :)
 

ASK THE COMMUNITY

TRENDING THREADS