Cambridge Audio Amp, Help Needed

admin_exported

New member
Aug 10, 2019
2,556
2
0
Hi Guys,

I've just purchased my first seperates system, i went for the Cambridge Azur amp. (340A SE)

The problem i seem to have is that no matter what is plugged in to the back of the unit, or to which input for that matter, it will only play the device plugged into the CD input. This is the case even when a different source is selected on the front of the unit!

I feel that it may be a suspect unit, but as the shops are closed i thought i'd try here for any tips/advice!

Cheers in advance.

Guy
 

d_a_n1979

New member
Sep 6, 2007
134
0
0
I'd say there's something wrong with it as if you select a different source and it's plugged into the correct inputs at the rear, then there's something not right.
 
A

Anonymous

Guest
[quote user="GuyM"]
Hi Guys,

I've just purchased my first seperates system, i went for the Cambridge Azur amp. (340A SE)

The problem i seem to have is that no matter what is plugged in to the back of the unit, or to which input for that matter, it will only play the device plugged into the CD input. This is the case even when a different source is selected on the front of the unit!

I feel that it may be a suspect unit, but as the shops are closed i thought i'd try here for any tips/advice!

Cheers in advance.

Guy

[/quote]

Have you tried connecting the device in to a different line in, then selecting that one on the front, i have the 640 model, where are you connecting the device, i know you say at the back but to what input and with what means, ie two channel interconnet, or some other way.
It does sound faulty - anyway, not long now 'till they open, go back, exchange it, maybe ask for a higher quality interconnect as means of compensation for all the wasted fuel, bus fare, car parking - and hassle!!
Well, you dont get if you dont ask!!!!
Let us know how you went on.
 
A

Anonymous

Guest
Thanks for the advice folks, it was indeed a faulty unit!

All praise to the guys at RicherSounds in cheltenham, they exchanged it no problem, and as always were extremely helpful!

I am now a happy man, listening to my music again!


Guy
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts